Village of Merrillan - Electric Outage - Degraded โ Incident details
Village of Merrillan
| Utility Status
Village Home
โ ๏ธ REPORT ISSUE
๐ฒ Sign-Up for Utility Alerts:
๐ฌ SMS
โ๏ธ Email
Get updates
Email
SMS
Webhook
RSS
Atom
Get updates
Dark mode
All systems operational
Electric Outage - Degraded
Resolved
Major outage
Started almost 2 years ago
November 18, 2024
Lasted 20 minutes
November 18, 2024
18:56
19:16
UTC
Updates
Resolved
November 18, 2024 at 19:16
UTC
Resolved
November 18, 2024 at 19:16
UTC
Electric is now operational!
Investigating
November 18, 2024 at 18:56
UTC
Investigating
November 18, 2024 at 18:56
UTC
We are investigating an electric issue within the Village.
UTC
UTC
UTC
UTC
UTC